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1 Introduction

Ce tutoriel a pour but de vous permettre la création d’un template de dessin sous NX. Il n’est pas consacré à la
création d’un dessin en tant que tel, cela étant réservé à un autre travail afin de ne surcharger inutilement ni celui-ci,
ni celui-là.

Prérequis Aucun

Objectifs À la fin de ce tutoriel, vous serez capable de

✠ Changer les informations données dans un cartouche

✠ Préremplir ou rendre interactif une série d’options dans ce cartouche

✠ Changer les dimensions de la page de dessin

2 Création du fichier

Avant toute chose, ouvrez NX en mode Administrateur. Pour ce faire, vous pouvez faire un clic droit sur le
raccourci de NX sur votre bureau et cliquer sur Exécuter en tant qu’administrateur. Il est aussi possible de faire la
même opération depuis le menu de recherche de votre ordinateur. Si vous n’ouvrez pas NX comme administrateur, il
ne vous sera pas possible de sauvegarder le template et vous devrez alors le recommencer à chaque fois.

1. Ouvrez un nouveau fichier (File → New) et sélec-
tionnez l’onglet de dessin (Drawing) dans la boîte
de dialogue.

2. Dans la section Relationship, sélectionnez l’option
Reference Existing Part. Cette option liera votre
dessin à la pièce que nous sélectionnerons plus bas.

3. Vérifiez que les unités utilisées pour ce dessin sont
bien les Millimeters.

4. Sélectionnez ensuite la taille A4 - Size.

5. Donnez un nom évocateur à votre pièce. Dans le
cadre de ce tutoriel, nommez votre épure Trois_vues

6. Vérifiez que le dossier dans lequel vous sauveg-
arderez votre pièce ne ressemble pas à .../Siemen-
s/NX/UGII. Vous ne pouvez pas écrire dans ce
dossier. Enregistrez plutôt votre épure dans le même
dossier que votre pièce.

7. Enfin, sélectionnez votre pièce dans la partie Part
to create a drawing of. Ici, vous pouvez pren-
dre n’importe quelle pièce que vous avez construit,
elle n’influencera pas notre travail ici. Si vous le
souhaitez, vous pouvez utiliser celle fournie avec ce
tutoriel.

Dans la boite de dialogue que vous voyez apparaître (Populate Title Block), vous pouvez éventuellement entrer
votre nom, mais nous modifierons cela plus tard. Vous pouvez vous contenter de fermer cette boite de dialogue.
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3 Modification de l’affichage de plusieurs types de lignes

Par défaut, NX n’affiche pas tous les types de lignes que nous utilisons en dessin technique. Fort heureusement,
il dispose d’une panoplie d’options qui permettent de changer ça. Tout d’abord, allez dans Menu → Preferences
→ Drafting. Une nouvelle fenêtre de dialogue s’ouvre. Dans l’ensemble des options proposées, allez en premier
dans l’option Drafting View → Workflow. Une fois sur place, décochez l’option Display que vous trouverez dans
la section Border. Aidez-vous de la Fig. 1 pour vous aider. Cette option enlèvera les cadres qui se présentent autour
des différentes vues que vous choisirez pour votre épure. Vous pouvez voir cette différence sur la Fig. 2.

Figure 1: Page de modification de bordure

Figure 2: Différence entre les vues avec ou
sans bordure

Sans quitter le menu de préférences, restez dans l’option Drawing View → Common → Hidden Lines. Là-bas,
vous aurez l’opportunité de rendre visible les différentes arrêtes cachées. Allez dans la partie Format et choisissez
de mettre des pointillés à la place de l’option Invisible. Aidez vous de la Fig. 3 et observez la modification grâce à la
Fig. 4.

Figure 3: Page de modification de l’affichage des lignes
cachées

Figure 4: Différence entre les vues avec ou
sans arrêtes cachées
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Toujours dans le menu de préférences, restez dans l’option Drawing View → Common → Smooth Edges et
désactivez-la. Aidez-vous de la Fig. 5 pour trouvez cette option. Vous pourrez ensuite voir son effet sur la Fig. 6.
Fermez ensuite cette boite de dialogue en cliquant sur OK.

Figure 5: Page de modification de l’affichage des bords
lisses

Figure 6: Différence entre les vues avec ou
sans bords lisses

La manipulation suivante aura pour but de modifier les marges de votre
dessin et de retirer les flèches que vous voyez sur les côtés. Pour ce faire,
rendez vous dans les Drafting Tools et cliquez sur l’option Borders and
Zones, comme montré par la Fig. 7.

Figure 7: Position de la commande Borders and zones

Dans cette boite de dialogue, commencez par aller dans la case Borders.
Là-bas, allez dans l’option Centering and Orientation Marks et réglez les
options Horizontal et Vertical sur None. Cela désactivera les flèches que
vous aviez pu voir sur la gauche et le bas du dessin.

Allez ensuite dans l’option Margins. Dans cette dernière, modifiez la
valeur de la zone Left pour la mettre à 5 à la place de 15. Cette action
modifiera la distance entre la marge et le bord de la feuille du côté gauche.
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4 Modification du cartouche

Une autre modification que nous allons apporter à ce dessin concerne son cartouche. Celui-ci reprend l’ensemble
des informations nécessaires pour la réalisation de nos pièces. C’est là que vous retrouverez le matériau, le nom de
la pièce, le nom du dessinateur, l’échelle utilisée, ... Commencez alors par aller dans la section View et modifiez la
Work layer de 1 à 256.

Allez ensuite sur le cartouche. Celui-ci devrait changer de couleur lorsque votre curseur se trouvera dessus. Faites
y un clic droit et sélectionnez l’option Edit Definition. Dans la fenêtre qui s’ouvre, allez sur l’option Select Tables.
Enlevez les grilles contenant du texte tout en conservant le dessin en bas à gauche dans la définition. Un exemple est
procuré ci-dessus.

Cliquez enfin sur OK pour fermer la fenêtre. Les différentes cases du cartouche peuvent maintenant être modifiées.
Commençons par l’institution d’origine du dessin. Pour ce faire, suivez les instructions suivantes

✠ Allez sur la case Siemens et faites un clic droit dessus.

✠ Sélectionnez ensuite l’option Edit Text.

✠ Dans la fenêtre qui s’ouvre, inscrivez ULiège. Cliquez sur OK lorsque c’est fait pour valider le changement.

Nous avons modifié le texte d’une première case. Nous allons maintenant modifier son affichage afin de le rendre plus
grand et de le mettre en gras. Pour ce faire,

✠ Retournez sur le case ULiège que vous venez de modifier

✠ Faites un clic droit et sélectionnez l’option Settings.

✠ Vous pouvez modifier la police d’écriture, son style et sa taille. Modifiez ces données afin qu’elles correspon-
dent à ce que vous voyez sur la Fig. 8.
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L’option Bold vous permet de mettre votre mot en gras, tandis que le champ Height vous permet de choisir la taille
de votre écriture. Modifiez les différentes cases du cartouche afin d’obtenir une version semblable à celle fournie
ci-dessous. La taille de l’écriture dans les différentes cases a été ici placée à 2.5 et la police d’écriture a été réglée
sur Times new roman. Ne remplissez pas encore vos noms, prénom et autres données. Une fois l’ensemble des
modifications du cartouche et de la feuille de dessin terminé, nous sauvegarderons un template pour ne plus devoir
faire ces modifications par la suite.

Figure 8: Cartouche final

Pour modifier la valeur de l’échelle et (éventuellement) la révision de votre
pièce dans le cartouche, sélectionnez l’option Edit Sheet disponible en dessous
de l’option New Sheet de l’onglet Home. Vous pourrez alors sélectionner facile-
ment la Scale de 1:1. Profitez du fait que vous soyez là pour également modifier
la Projection dans l’onglet Settings. En effet, par défaut, NX est réglé pour in-
diquer les vues de la convention américaine. Sélectionnez donc le symbole de la
convention européenne, montré par la Fig. 9.

Figure 9: Symbole de la convention européenne de dessin
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5 Sauvegarder le template

Si vous voulez utiliser à l’avenir un template que vous avez créé, nous allons ajouter quelques étapes à la définition
de votre cartouche. Celles-ci vous premettrons de remplir automatiquement le cartouche que nous venons de modifier.

1. Tout d’abord, faites un clic droit sur le morceau de Title Block que vous avez laissé. Si vous ne le retrouvez
pas, sélectionnez la commande Define Title Block dans la section Drafting Tools

2. Sélectionnez les trois éléments qui vous sont présentés par la figure ci-dessous dans la partie Select Tables.
Cela remettra l’ensemble du cartouche dans une option non modifiable.

3. Dans l’onglet Cell Properties, ajoutez un blocage sur les cases ayant une définition "fixe", comme les cases
Nom, Prénom, ... afin que les futures utilisations ne puissent pas les modifier. Pour faire ça, sélectionnez la
ligne désirée (par exemple celle où la Value est ULiège) et cochez la case Lock au sommet du tableau. Un petit
symbole de verrou apparaîtra alors.

4. Modifiez le Label des cases variables qui correspondent à vos cases fixes. La figure ci-dessous vous propose un
exemple de réalisation. Les noms que vous donnerez ici vous seront indiqués lorsque vous utiliserez plus tard
l’option permettant de remplir le cartouche (l’option Populate Title Block que nous avons passé plus haut).
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5. Une fois toutes les cases bloquées ou nommées, vous pourrez utiliser la commande Populate Title Block pour
remplir les différentes options laissées libres lors de votre future utilisation du template. Dans ce cas, vous
pourrez voir une fenêtre comme celle présentée ci-dessous.

Une fois ces différentes actions effectuées, nous allons faire en sorte de conserver ce template afin de ne pas
devoir faire ces différentes manipulations plusieurs fois. Il existe deux méthodes pour y arriver. La première est
plus complexe, mais permet de retrouver très facilement notre template. La seconde est plus facile, mais bien moins
"propre". De plus, lors de son utilisation, vous aurez un avertissement sans conséquence du programme.

Première méthode: création d’un fichier PAX

Si vous n’avez pas démarrer NX en mode Administrateur, sauvegarder votre template et fermer NX. Si vous avez fait
cette manipulation au début du tutoriel, commencez directement au point 3.

1. Cherchez NX dans la barre de recherche rapide de votre bureau (en bas à gauche) et lancer NX 18.0 en mode
administrateur.
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2. Créez/ouvrez le fichier que vous voulez transformer en template. Vous pouvez utiliser celui que vous venez
juste de créer, mais assurez vous que les éventulles différentes vues et cotes soient enlevées avant la suite des
opérations. Si vous laissez des vues/cotes sur le template, vous les conserverez dans le template.

3. Cliquez sur la touche Mark as Template dans la section Drafting Tools

4. Dans la fenêtre qui s’ouvre, utilisez les options présentées par la figure ci-dessous. Sélectionnez mark as
Template and Update PAX File dans l’option Action.

5. Vérifiez que vous avez bien sélectionné Reference Existing Part dans l’option Template Type.

6. Choisissez comme PAX File C\Program Files\ Siemens\ NX\Drafting\templates\ un nom au choix.

7. Cliquez sur OK sur les différentes fenêtres ouvertes.

8. Sauvegardez votre fichier de dessin au même endroit que votre fichier PAX. Vous pouvez sauvegarder ce dessin
sous un fichier de votre choix grâce à la commande File → Save → Save as...

9. Fermez NX et redémarrez le programme normalement. Lorsque vous irez créer une nouvelle épure, vous
pourrez choisir votre template, qui devrait apparaître dans les options de dessin.
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Seconde méthode: Sauvegarder le fichier à un endroit sécurisé

Ici, la méthode consiste juste à sauvegarder votre dessin dans un fichier et à ne plus y toucher. Pour ce faire, allez
dans Files → Save as et sélectionnez un dossier facile d’accès. Lorsque vous débuterez un nouveau dessin, vous aurez
un message d’erreur vous disant que la pièce de base est introuvable. Vous devrez penser à sauvegarder vos dessins
sur un emplacement autre que celui où vous avez mis votre template, car vous pourriez "contaminer" ce dernier. Cette
méthode est bien plus bancale, mais fonctionne si vous ne pouvez appliquer la précédente.

Attention Si vous avez le choix, utilisez la première méthode. La seconde est une roue de secours.
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